Formules Excel pour le SEO et le SEA

L’utilisation d’Excel est largement répandue chez les search marketers. Le tableur de Microsoft permet de traiter en masse les données dont le référenceur dispose, pour constituer ses dashboards et ses autres outils quotidiens.

Cet article regroupe différentes formules très pratiques dans certains cas. A vous de les adapter aux vôtres.

Extraire une partie du texte d’une cellule

Vous souhaitez extraire d’une cellule ce qui précède un terme, utilisez ce code :

=GAUCHE(cellule;TROUVE("texte";cellule;1)-1)

Vous souhaitez extraire d’une cellule ce qui suit un terme ? Utilisez la formule suivante :

=DROITE(cellule;NBCAR(cellule)-TROUVE("texte";cellule;1)+1)

Supprimer des caractères dans une chaîne de caractères

Vous souhaitez supprimer des caractères dans une texte ? Si le nombre de caractères à supprimer est fixe, voici 2 formules.

Supprimer les premiers caractères d’une chaîne, par exemple pour extraire du nom d’une publicité le nom du groupe d’annonces auquel elle appartient

=DROITE(cellule;NBCAR(cellule)-nombre de caractères à supprimer)

Supprimer les derniers caractères d’une chaîne :

=GAUCHE(cellule;NBCAR(cellule)-nombre de caractères à supprimer)

Vérifier si une cellule contient un mot parmi une liste de mots

Si on trouve mot1 ou mot2 … jusqu’à mot8 dans la cellule A1, on affiche OK dans la cellule contenant la formule :

=SI(SOMMEPROD(N(ESTNUM(TROUVE({"mot1"; "mot2" ;"mot3"; "mot4" ;"mot5"; "mot6"; "mot7"; "mot8"};A1))))>0;"OK";"PAS OK")

Identifier les doublons sans les supprimer

Version basique d’une version qu’on développera par la suite, cette formule permet d’identifier des doublons sans les supprimer :

=SI(cellule1=cellule2;"doublon";"")

Compter le nombre de caractères d’une cellule

Pratique pour vérifier la longueur des H1, meta description, titre d’annonce ou lignes descriptives sur AdWords ou Bing, cette formule calcule le nombre de caractères contenus dans une cellule :

=NBCAR(cellule)

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Fill out this field
Fill out this field
Veuillez saisir une adresse de messagerie valide.
Vous devez accepter les conditions pour continuer

La modération des commentaires est activée. Votre commentaire peut prendre un certain temps avant d'apparaître.

Menu